Installation Notes

Supported Operating Systems

The Cogent DataHub supports the following operating systems:

Operating System Minimum Requirements
Windows XP (32-bit & 64-bit) Service Pack 3 (SP3) + .NET 2.0 & .NET 4.0
Windows Server 2003 & R2 (32-bit & 64-bit) Service Pack 2 (SP2) + .NET 2.0 & .NET 4.0
Windows Server 2008 & R2 (64-bit) Service Pack 1 (SP1) + .NET 4.5 *
Windows Server 2012 & R2 (64-bit) Service Pack 1 (SP1) + .NET 4.5 *
Windows 7 (32-bit & 64-bit) Service Pack 1 (SP1) + .NET 4.5 *
Windows 8.1 (32-bit & 64-bit) .NET 4.5 *
Windows 10 (32-bit & 64-bit) .NET 4.5
Windows Server 2016 (64-bit) .NET 4.5

* If .NET 2 and .NET 4.0 are both installed then .NET 4.5 is not required.

Product Minimum Requirements
DataHub WebView Internet Explorer 9 or later
SkkyHub WebView Internet Explorer 11 or later

DataHub installer

The DataHub installer makes the following decisions when installing the product:

  1. If .NET 4.5 is installed, then proceed with the installation.
  2. If installing on Windows XP or Server 2003, then install .NET 2.0 and .NET 4.0. If either of these are already installed, then it will not install them again.
  3. If the O/S is not Windows XP or Server 2003, then look to see if .NET 2.0 or .NET 4.0 are installed and install whichever one is missing.
  4. If the O/S is not Windows XP or Server 2003 and neither .NET 2.0 nor .NET 4.0 are installed, then install .NET 4.5.

Windows XP

In order to run the DataHub in Windows XP, you need to have XP Service Pack 3 installed.  It is recommended that you install all O/S updates.

It is possible to install the DataHub with only XP Service Pack 2 and the DataHub will run, but the DataHub UA Server feature will not be able to use the Local Discovery Service utility unless you are running SP3.

In order to run the DataHub on Windows XP SP2, you will need to install the following components before running the DataHub installer:

Windows Server 2003 and 2003 R2

In order to run the DataHub in Windows Server 2003, you need to have Service Pack 2 installed.  It is recommended that you install all O/S updates.

Windows Server 2003 Service Pack 1 contains the Windows Installer v 3.1., but depending on the updates you have installed, you may need to install the Windows Image Component in order to install .NET 4.0.

Windows 7

In order to run the DataHub in Windows 7, you need to have Service Pack 1 installed.  It is recommended that you install all O/S updates.

Windows Server 2008 and 2008 R2

In order to run the DataHub in Windows Server 2008, you need to have Service Pack 1 installed.  It is recommended that you install all O/S updates.

Windows 8 and 8.1

To install DataHub on Windows 8 it is recommended that you have all O/S updates installed.  It is recommended that you install all O/S updates.

Note:  In Windows 8 the Microsoft 2015 C++ Redistributable can take several minutes to install. Sometimes the C++ installation does not complete, and will just pause.  To get it to work, close the C++ install, which lets me complete the DataHub install, and then run the DH installer a second time.  In some cases, you may have to uninstall the 2015 C++ Redistributable and then run the DH installer again.  This is a problem with the redistributable, not the DataHub installer.

Windows 2012 and 2012 R2

In order to run the DataHub in Windows Server 2012, you need to have Windows Server 2012 R2 Update (KB2919355) installed (see link below).  This installation may require you to install other update prior to installing this one and so it is recommended that you install all O/S updates.

Windows 10 and Server 2016

There are no known issues installing the DataHub on Windows 10 or Server 2016, but please refer to Known Issues if you plan to run the DataHub as a Windows service on either of these operating systems.